NanoX - s88 all in one.. probleme la partea s88

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
Salut,
eu tot n-am gasit nici o schema, doar poze de la layout, asa ca pentru a vedea ceva am suprapus cele doua poze (brd si silk) si mi-a iesit o noua poza. Si cand eram gata, m-am uitat si la celalat fisier cu silk si am obtinut acelasi lucru, numai mai bine facut.
7404 pare conectat cum trebuie. Ce ai mai putea testa:
- masoara tensiunea pe pinul 14 al lui 7404 (fisa neagra la GND/pinul 7, fisa rosie pe pinul 14). Ar trebui sa fie ~5V.
- masoara tensiunea pe pinul 9 al lui 7404. Ar trebui sa ai 0 curat (sau aceeasi valoare ca cea masurata cand scurcircuitezi fisele aparatului de masura.
- masoara tensiunea pe pinul 8 al lui 7404. Ar trebui sa ai ~5 V.
Spor,
Liviu
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
danezu post_id=165258 time=1518981374 user_id=1073 a spus:
iar cand puns vss pe data se aprind
VSS (=GND) sau VCC?
Daca chiar e chiar VSS, atunci ai probleme cu rezistenta R12. Pare in aer.
 

danezu

Well-Known Member
Trenulist
16 Septembrie 2009
419
90
32
Los Angeles
LOCATION
Los Angeles
- masoara tensiunea pe pinul 14 al lui 7404 (fisa neagra la GND/pinul 7, fisa rosie pe pinul 14). Ar trebui sa fie ~5V.

AM 5.8V (7805 imi da5.8v)

- masoara tensiunea pe pinul 9 al lui 7404. Ar trebui sa ai 0 curat (sau aceeasi valoare ca cea masurata cand scurcircuitezi fisele aparatului de masura.

am 2.4v

- masoara tensiunea pe pinul 8 al lui 7404. Ar trebui sa ai ~5 V.

am 0.8v


Asta ptr schema ALL IN ONE unde pinii 7404n difera de nanox s88 v3
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
danezu post_id=165261 time=1518982587 user_id=1073 a spus:
Prea mult.
Masoara si cele doua capete ale R12 fata de pinul 7 al 7404 - prima data negru la pinul 7, rosu la un capat al rezistentei, dupa negru tot la pinul 7, rosu la celalalt capat al rezistentei.

PS Si cei 5.8 V sunt cam mult (in foile de catalog VMax pentru 7404 e 5.25 V), da' nu cred ca e de acolo.
 

danezu

Well-Known Member
Trenulist
16 Septembrie 2009
419
90
32
Los Angeles
LOCATION
Los Angeles
LiviuM post_id=165264 time=1518983099 user_id=1702 a spus:
danezu post_id=165261 time=1518982587 user_id=1073 a spus:
Prea mult.
Masoara si cele doua capete ale R12 fata de pinul 7 al 7404 - prima data negru la pinul 7, rosu la un capat al rezistentei, dupa negru tot la pinul 7, rosu la celalalt capat al rezistentei.

R12.. Partea dinspre releu 0v
Partea dinspre mufarj45 1.6v

PS Si cei 5.8 V sunt cam mult (in foile de catalog VMax pentru 7404 e 5.25 V), da' nu cred ca e de acolo.

sa pun o dioda sa mai taie din cei 5.8? as putea taia jumperul ptr pin 14 si sa pun o dioda?


R12.. Partea dinspre releu 0v
Partea dinspre mufarj45 1.6v
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
danezu post_id=165265 time=1518983484 user_id=1073 a spus:
R12.. Partea dinspre releu 0v
Aici e masa, e bine.
danezu post_id=165265 time=1518983484 user_id=1073 a spus:
Partea dinspre mufarj45 1.6v
Aici e prea mult, dar m-as fi asteptat sa fie aceiasi 2.4 V de pe pinul 9 al 7404. Hmm, ciudat rau, pare sa curga niste curent aiurea pe acolo si nu ma prind unde. Sigut n-ai nici un scurt pe la jumperii aia, da? 7404 e pe soclu, sau lipit? Poti sa repeti masuratorile (pinul 9 si rezistenta)?
danezu post_id=165265 time=1518983484 user_id=1073 a spus:
sa pun o dioda sa mai taie din cei 5.8? as putea taia jumperul ptr pin 14 si sa pun o dioda?
Eu as inlocui direct pe iesirea lui 7805. Daca vad eu bine, e junperul dintre C3 si C5.
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
Masoara si intre pinul 2 al mufei S88 si pinul 7 al 7407, numai asa, sa fim siguri ca 7404 e bine alimentat.
 

danezu

Well-Known Member
Trenulist
16 Septembrie 2009
419
90
32
Los Angeles
LOCATION
Los Angeles
Prima data am pus testeril negru la gnd principal si rosu la pin 9 ,nu pin 7. Pin 7 cu pin 9 e 1.6v

Am sa verific mai tarziu altfel nevasta ma va omora daca mai petrec mult timp pe electronice.

ReVerific totti pasii si revin cu update uri

Multumesc mult
 

danezu

Well-Known Member
Trenulist
16 Septembrie 2009
419
90
32
Los Angeles
LOCATION
Los Angeles
La ce va referiti sa schimb iesirea 7805?
Eu ma gandeam la o dioda pe jumperil dintre c3 si c3 care duce la pun 14 si probabil si dintre c3 si c5
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
danezu post_id=165271 time=1518986085 user_id=1073 a spus:
La ce va referiti
La ce te referi, ca-s singur. :D
danezu post_id=165271 time=1518986085 user_id=1073 a spus:
Eu ma gandeam la o dioda pe jumperil dintre c3 si c3 care duce la pun 14 si probabil si dintre c3 si c5
Eram de acord cu solutia si sugeram sa inlocuiesti jumperul dintre C3 si C5 cu dioda respectiva, ca sa alimentezi si picul cu 5V, nu doar 7404.
Vorbim de acelasi lucru, se pare.
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
danezu post_id=165270 time=1518985802 user_id=1073 a spus:
gnd principal si rosu la pin 9 ,nu pin 7. Pin 7 cu pin 9 e 1.6v
Se pare c-ai o problema cu alimentarea (masa) lui 7404. Asta trebuie rezolvata prima.
Verifica lipiturile si jumperul care duce la pinul 7 al 7404.
Acum ma duc la culcare. Mai vedem maine.
 

danezu

Well-Known Member
Trenulist
16 Septembrie 2009
419
90
32
Los Angeles
LOCATION
Los Angeles
Am racait intre toate traseele si verificat toate lipiturile.
masuratorile facute anterior erau deplasate deoarece foloseam GND de la intrarea in care este prezenta o semipunte. cu GND dupa dioda by255 care duce la pin7 rezultatele sunt:

masuratorile sunnt fara s88_sch module in:


pin7 cu pin14 5.05V
cu pin 8 0.02v
cu pin9 1.62v
cu R12 releu side 0v
cu r12 rj45 side 1.62v (daca scot 7404n acesta e 0V)

pin9 cu r12 releu 1.62v
pin9 cu r121 rj45side 0v

pin 2 s88 cu pin 7 0v

:(|) din cate inteleg pin 8 ar trebui sa fie 5v si pin 9 0v..

fara 7404n in soclu senzorii sunt off. cand pun testerul pe pin7 si pin 8 sau 9 se aprind
 

danezu

Well-Known Member
Trenulist
16 Septembrie 2009
419
90
32
Los Angeles
LOCATION
Los Angeles
P.s. Am testat 3 diferite sn7404n-uri.. acelasi rezultat dezamagitor :( plus o nevasta suparata :roll:
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
Salut,
danezu post_id=165278 time=1519006129 user_id=1073 a spus:
cu GND dupa dioda by255 care duce la pin7
Care dioda? Poti sa-mi spui numarul ei in poza All_in_One.zip\Detlef\All_in_One_brd_silk.pdf?
danezu post_id=165278 time=1519006129 user_id=1073 a spus:
cand pun testerul pe pin7 si pin 8 sau 9 se aprind
Cu 7404 montat, sau fara?

Masoara eventual si curentul cand faci scurtul intre Data si Vss (GND) - fara s88_sch pui multimetrul pe curent si il folosesti sa faci scurtul. Conform foii de catalog, ar trebui sa ai max 1.6 mA. Nu de alta, dar m-am uitat acum in schema interna a 7404 si sunt sanse sa nu fie chiar asa nasol. Intrarile nu-s chiar asa de "fara curent" cum imi imaginam eu, asa ca acei 1.6 V pe intrare s-ar putea sa fie OK.
M-am uitat acum si la caracteristicile lui 4014 si asta e cam anemic, nu-mi dau seama cum reusesc sa mearga impreuna modulele astea doua. Pentru ca e clar ca merg, par sa fie o gramada de oameni care le foloseste.
Cu alte cuvinte, se pare ca problema ta ma depaseste. Incet, incet renunt sa te mai incurc. Ca am senzatia ca asta am facut pana acum. Sorry.

Liviu
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
Salut, tot eu.

Stiu ca nu e chiar cel mai potrivit raspuns, da' eu as incerca cu un CD4069 in locul lui 7404.
E compatibil la pini si, desi e ceva mai lent, ar trebui sa mearga (chiar mai bine) in aplicatia asta.
Sau un alt inversor CMOS compatibil la pini cu 7404.
Asta daca nu-i prea complicata procurarea lui.

A, si inca ceva. Leaga pinul 5 al lui 7404 la masa (e aproape, n-ar trebui sa fie o problema). Nu e bine sa lasi in aer intrarile nefolosite.

Spor,
Liviu
 

LiviuM

Well-Known Member
Trenulist
11 Martie 2011
397
0
A propos, tu esti sigur ca s88_sch functioneaza cum trebuie, da? :D
Adica ai un 0 ferm pe pinul 1 / Data Out, da?