PROBLEME DE FUNCTIONARE NANO X-S88

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Buna ziua tuturor!
Din necesitatea de a putea citi CV-urile , nu doar de a le putea scrie, m-am decis sa construiesc Nano x-s88. Dupa ce l-am terminat, la probe, am constatat ca montajul nu functioneaza. Proba a fost facuta cu un multimaus Roco, pe ecranul caruia mi-a afisat "STOP" . Tot la pornire se anclansaza releul pentru programare si nu se aprinde LED-ul.Am verificat iesirile de la: LM350(18,35v), 7805(5,07v) si 7812(11,85v). Deasemeni am verificat cablajul si lipiturile de pe acesta toate par ok. Pe fiecare din iesiri (programare si DCC) am masurat o rezistenta de circa 80 ohm. Integratul L6203 este alimentat la pinii 2 si 6 cu o tensiune de 18,35v. Daca puteti va rog sa ma ajutati in rezolvarea acestei probleme.
Cu stima Eugen
 

Elef

Well-Known Member
Trenulist
18 Mai 2007
437
15
Bucuresti
LOCATION
Bucuresti
Verifica montajul din nou.
Tot la pornire se anclansaza releul pentru programare si nu se aprinde LED-ul

La pronire respectivul releu trebuie sa fie neaclansat.El se aclanseaza doar la protecitia la scurtcircuit caz in care ledul clipeste repede parca si la programare caz in care ledul clipeste lent.

Oricum porneste nano-x-ul fara mouse atasat si vezi cum se comporta.Daca ledul nu se aprinde si releul tot aclansat este este o problema cu montajul tau.
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Am pornit nano x-ul fara moue si situatia ramne aceeasi. Din cate am vazut eu in documentatie rolul releului este de a comuta de pe linia dioramei pe linia izolata de programare dar, e foarte posibil sa fie si protectie la scurt circuit. Voi verifica din nou circuitul si nu stiu daca se impune sau nu sa reprogramez PIC-ul. Acesta poate fi programat in 3 moduri si anume: pentru a lucra cu cristal de quart de 4Mhz, de 8 Mhz, sau fara cristal. Initial l-am programat pentru un cristal de 4 Mhz.
 

Elef

Well-Known Member
Trenulist
18 Mai 2007
437
15
Bucuresti
LOCATION
Bucuresti
Acesta poate fi programat in 3 moduri si anume: pentru a lucra cu cristal de quart de 4Mhz, de 8 Mhz, sau fara cristal. Initial l-am programat pentru un cristal de 4 Mhz.

Si ai prevazut cristalul de 4Mhz in montaj?
Cel mai bine incearca sa programezi pic-ul cu varianta fara cristal.
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Am prevazut si cristalul de 4Mhz si cei 2 condensatori de 22pF. O sa reprogramez PIC-ul si o sa scot din montaj cristalul si cei doi condensatori sa vedem ce se va intampla.
 

blueicon

Member
11 Martie 2008
39
0
Bistrita
LOCATION
Bistrita
Daca totul e k releul nu trebuie sa aclanseze.Daca ai posibilitatea scoate la6203 si vezi cum se comporta.La mine cu pic si quartz de 4 Mhz functioneaza foarte bine.Releul cupleaza la scurtcircuit .
 

Elef

Well-Known Member
Trenulist
18 Mai 2007
437
15
Bucuresti
LOCATION
Bucuresti
Am prevazut si cristalul de 4Mhz si cei 2 condensatori de 22pF. O sa reprogramez PIC-ul si o sa scot din montaj cristalul si cei doi condensatori sa vedem ce se va intampla.

Daca led-ul e legat corect atunci as zice ca s-ar putea sa nu mearga oscilatorul.Incearca sa legi capsula cristalului la masa (firul sa fie cat mai scurt).
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Am reprogramat PIC-ul sa functioneze fara cristal, am scos cristalul din circuit, l-am pornit fara mouse si situatia ramane neschimbata. Problema este in alta parte dar nu stiu unde.
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Intre timp am schimbat si LED-ul care cedase nervos. Dupa schimbare cel nou a inceput sa se aprinda intermitent ceea ce inseamna ca e un scurt undeva. Ma mai uit pe circuit poate descopar ceva.
 

blueicon

Member
11 Martie 2008
39
0
Bistrita
LOCATION
Bistrita
Problema trebuie sa fie la LA6203.Trebuie sa ai scurt sau daca nu ai o componenta defecta.Iesirea nu are rezistenta//ma rog arata 40 de Mohmi la mine.Scoate un capat al rezistentei care este in serie cu un condensator pe iesire.Releul este in regula ,nu e cumva cu alta asezarea a contactelor.Lasa quartzul ca merge bine cu el.Intrerupe traseul de iesire direct de la pinul integratului si vezi asa ca sa te prinzi unde e probelam.LA6203 nu se incalzeste?Pai de ce a cedat ledul?Nu avea voie.Sigur ai un scurt pe acolo.
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Am intrerupt circuitul de la L6203 in dreptul pinilor 2 si 3. Mare minune mare releul nu mai anclansaza si LED-ul ramane aprins. Maine cand voi fi odihnit voi cauta scurtul. Va multumesc foarte mult pentru ajutorul pretios pe care mi l-ati dat.
Cu respect Eugen
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Am descoperit unde era problema. Din dorinta prea mare de a proba circuitul si in absenta releului care vine montat pe placa, am facut o improviztie cu un alt releu pe care l-am legat la montaj cu ajutorul unor conductori. Din gresala am inversat doi dintre acestia si de aici a intervenit problema. Acum LED-ul sta permanent aprins, releul reactioneaza atat la scurt cat si la programare. Cand va sosi si decodorul va voi informa daca exista diferente de functionare intre modelul cu cristal si cel fara(acum cristalul este scos din circuit).
Va doresc o zi buna tuturor
 

blueicon

Member
11 Martie 2008
39
0
Bistrita
LOCATION
Bistrita
Nu ar trebui sa existe nici o diferenta in functionare daca se foloseste quartz sau oscilator intern.Oricum ca o parere personala zic ca e mai bine cu un quartz.De citit citeste valorile din CV cu multimouse de la roco.
 

Horia_Radulescu

Consilier tehnic
Super Moderator
Trenulist
14 Februarie 2008
6.127
1.101
Mulhouse, Alsacia
LOCATION
Mulhouse, Alsacia
mai Mircea, orice Multimaus citeste CV-uri de la mama lui, numai ca centrala nu stie...

pune un Multimaus normal, cu fir (rosu) pe centrala noua, de la Multimausul Wireless (albastru) si va citi toate CV-urile!
 

mpursu

Well-Known Member
Trenulist
25 August 2007
3.512
286
Oradea
railcrisana.wordpress.com
WEBSITE
https://railcrisana.wordpress.com/
LOCATION
Oradea
YOUTUBE
mpursu
Sa-i fie de bine ca stie, la fel si mie ca stiu ca stie, la fel si tie ca stii ca stiu ca stie :D
Problema mea este ca NU l-am vazut niciodata "live" citind si afisand valorile reale ale CV-urilor, din motivele deja cunoscute, respectiv din cauza centralei care nu-i ofera datele adecvate.
Off-topic: va multumesc tuturor pentru ca, impreuna cu voi, am ajuns la mesajul 1500 pe acest forum 8)
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
blueicon a spus:
Nu ar trebui sa existe nici o diferenta in functionare daca se foloseste quartz sau oscilator intern.Oricum ca o parere personala zic ca e mai bine cu un quartz.De citit citeste valorile din CV cu multimouse de la roco.
Si eu sunt de acceasi parere dar, daca PIC- ul a ramas programat in varianta fara cristal, mi-am propus sa fac o proba si asa.
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
mpursu a spus:
Problema mea este ca NU l-am vazut niciodata "live" citind si afisand valorile reale ale CV-urilor, din motivele deja cunoscute, respectiv din cauza centralei care nu-i ofera datele adecvate.
Curiozitatea iti va fi satisfacuta in momentul in care voi primi primul meu decodor. Ar mai fi o varianta mai rapida dar nu stiu daca santierul iti permite. :D
 

wlab7180

Active Member
Trenulist
25 Noiembrie 2008
152
0
Oradea
LOCATION
Oradea
Am primit decodorul mult dorit si l-am montat pe un BR 218. ACUM AM SI EU PRIMA MEA LOCOMOTIV DIGITALA . :D Multumiri lui MPURSU pentru ajutorul acordat in montarea acestui decodor. Cu ajutorul noii locomotive digitale am reusit sa probez si Nano x, care functioneaza foarte bine fara cristal. Cu aceasta ocazie a fost satisfacuta si dorinta lui Mircea de a vedea live multimouse-ul de la Roco citind corect CV-uri.
 

mpursu

Well-Known Member
Trenulist
25 August 2007
3.512
286
Oradea
railcrisana.wordpress.com
WEBSITE
https://railcrisana.wordpress.com/
LOCATION
Oradea
YOUTUBE
mpursu
Felicitari Wlab7180! 8) :aplauze::aplauze::aplauze:
Succesul tau este cu atat mai mare cu cat prima ta locomotiva digitalizata NU avea interfata digitala, deci tu ai facut manual toate conexiunile adecvate :aplauze: inca si ceva in plus :D
De asemenea, multumesc pentru momentu-acela perfect (vorba simpaticei Andra) in care am putut sa admir Multimousele citind corect valorile CV-urilor, conectat fiind la statia Nanox perfect functionala 8)