• Forumul este in proces de upgrade!

Comanda macaze cu informatie pozitie

cristi_m

Well-Known Member
#21
Probabil apare o variatie de tensiune pe circuitul de alimentare. Incearca sa pui intre "plus" si masa un condensator electrolitic de capacitate mare!
 

interzis

Active Member
#22
pune acel condensator de care zice cristi_m pe sursa dar pune si cate unul mai mic, 100uF, pe fiecare bistabil.

testeaza doar la 2-3 montaje si vezi daca alea "scapa" de resetare.

verifica si daca sursa "duce" suficient curent astfel incat sa nu fie afectata de consumul suplimentar al electromagnetului (cat consuma electromagnetul?)
 

sogard_2003

Well-Known Member
#23
Am facut din nou teste. Am montat un condensator mai mare dupa sursa de alimentare care este facuta cu un LM317 reglat la 15V. Capacitatea condensatorului este de 4700uF la 25 de volti.... pe placa cu bistabile am deparazitat cu cateva condensatoare de 100nF si am filtrat din nou cu un condensator de 2200uF .... bobinele sunt legate dupa buton, si dse duc catre plusul montajului.... am incercat si montarea unei diode antiparalel cu bobina insa fara rezultat. Cand actionez unul din butoane , toate bistabilele ramase se reseteaza.

Dragos
 

interzis

Active Member
#24
din cate retin LM317 nu duce decat 1-1,5A
posibil ca asta sa fie cauza - in cazul in care electromagnetul consuma mult...

ai masurat cat consuma?

ia incearca sa pui 2 electromagneti in serie si vezi daca se mai reseteaza bistabilele, chiar daca nu vor actiona electromagnetii.

PS: ai fi scapat de toate problemele astea cu relee latch ;)
 

dac

Well-Known Member
#25
E posibil un cuplaj electromagnetic intre bobine ? Actionarea uneia sa induca tensiuni in celelalte si prin dioda sa deschida tranzistorul aferent ?

Incearca si surse diferite pt. electromagneti, respectiv bistabile (dar cu masa comuna).

Testeaza si reducerea valorii rezistentelor de 27 kohm la 10 kohm, sau chiar mai jos.
 

sogard_2003

Well-Known Member
#26
You do not have permission to view link Autentificare sau înregistrare acum


Multumesc Andrei pentru ajutor cu urcatul pozei pe cont.

Am atasat si poza. Am sa iau in calcul alimetarea independenta a macazelor. Ideal era sa am butoane duble fara retinere si rezolvam problema cu dubla alimetare. Acuma deja sunt luate, aproape 40 de butoane, montajul e facut, merge dar fara bobine. Ma mai gandesc la o izolare electronica. Cu un tranzistor sau un optocuplor... sa vedem... :)
 

interzis

Active Member
#27
AW!
pai electromagnetul tau pune baza tranzistorilor in masa! e ca si cum ai apasa butonul!

LATER: scuze, m-am grabit! e "+" nu e masa!
revin la parerea cu consumul electromagnetului
 

mity

Well-Known Member
#28
Daca schimbi diodele 1n4148 care au cotul Zenner la 100V cu diode 1N4007 care au cotul Zenner la 1000V scapi de belea. Spor.

P.S. Când eliberezi butonul, tensiunea auto-indusa se pare ca este mai mare de 100V şi stră’punge dioda 1N4148.
 

dac

Well-Known Member
#29
Daca ledurile sunt de culori diferite, atunci montajul este usor asimetric si cum tensiunea de deschidere a ledului rosu este mai mica decat a celui verde, este favorizata comutarea catre aprinderea primului.

Pentru cresterea stabilitatii se poate incerca scaderea valorii rezistentelor din bazele tranzistoarelor, sau montarea unor condensatoare de 100nF in paralel pe acestea.
 

sogard_2003

Well-Known Member
#30
Mity, am luat in calcul tensiunea de strapungere a diodelor si nu este vorba despre asta. Iti spun pentru ca am montat de la bun inceput 1N4004 care dupa cum spune catalogul au 400V tensiune de strapungere. Nu cred ca bobinele astea pot induce un curent atat de mare dupa decuplare chiar daca au un numar asa ridicat de spire. Ma mai gandesc la posibilitatea inserierii a mai multor diode... nu stiu. trebuie sa mai fac teste cand ajung acasa.
 

dave

Active Member
#31
Din cate vad eu, tensiunea in colectorul tranzistorului aflat in conductie (cel cu led-ul aprins la un moment dat) este de cca 2V, adica Uled+Uce. Acea tensiune ajunge si in baza celuilalt tranzistor, care ar trebui sa aiba sub 0.6V ca sa nu intre in conductie. Daca ai monta LED-urile in colectorul tranzistoarelor, adica intre R3 si nodul R1+colectorQ2, respectiv R4 si nodul R2+Q2?

In plus, sursa de alimentare trebuie sa fie solida, facuta cu un traf de minim 2-3A, punte de minim 3A si condensator de filtraj de 470-1000UF

Si daca butoanele de actionare sunt la distanta de bistabile, prin manunchi fire lungi paralele, sa pui si condensatoare de 10...100nF intre baze si emitoare.
 

dac

Well-Known Member
#32
Ledurile nu se pot muta in circuitul de colector pt. ca ar contribui la polarizarea tranzistorului opus si nu s-ar stinge complet la blocarea tranzistorului propriu.

Tensiunea de deschidere este Ube + Uled care este cu cel putin 0,5V mai mare decat Uce + Uled si satisface conditia de stabilitate. Daca ledurile nu sunt identice iar tensiunile de deschidere difera cu 0,5V pot aparea probleme de comutare. Solutia ar fi inserierea unei diode 1n4148 cu ledul avand tensiunea de deschidere mai mica (rosu).
 

interzis

Active Member
#33
pfff... deja ajungem sa imperechem si tranzistorii? cautam si rezistente cu tolerante sub 1%? ce iese? nasa?
dac, e doar un nenorocit de bistabil, chiar crezi ca diferenta de consum intre led rosu si led verde conteaza? io unu nu cred!
 

dave

Active Member
#34
Cred ca am fost inteles gresit, insa oricum si schema originala aratata mai sus ar trebui sa functioneze. Eu cam asa ma gandeam in postul anterior:


Eu as verifica din nou sursa de alimentare si as pune condensatoare in bazele tranzistoarelor,, catre masa.
 

dac

Well-Known Member
#35
In varianta asta, cand tranzistorul corespunzator este blocat, prin led trece totusi curentul de baza al celuilalt tranzistor si va lumina slab.

Solutia este utilizarea a inca o pereche de tranzistoare, cuplate in darlington cu primele si in al caror colector sa se regaseasca ledurile cu rezistentele de limitare.

Dublandu-se practic nr de componente, scade insa eficienta "tehnologica"...
 

IronM

New Member
#36
Salutare,

Am sa incerc sa invii acest topic. Pana la urma, s-a aflat solutia buna? :)

Eu sunt la inceput de drum si vreau pe o diorama TT sa pun niste leduri pt pozitia macazelor (electrice, Berliner TT Bahnen), 4 la numar, alimentate in AC (16-17V /1,2A) de un Piko FZ1.

Vreau sa-mi ramana aprinse pt a sti oricand pozitia macazelor (vreau sa pun cate 2 si pe diorama, pe post de semnale pitice si cate 2 pe panoul de control - am gasit niste butoane misto, cu sageti luminoase:) ).
 
Sus Jos