Decodor accesorii

11 Mar 2008
39
0
Bistrita
LOCATION
Bistrita
#1
Va salut!
As avea nevoie de ajutor de la specialisti daca se poate.Am facut un decodor pentru accesorii:
http://i131.photobucket.com/albums/p291/blueicon/dccacc.gif
de pe site-il lui Paco.Pana acum toate bune tot ce am facut a functionat dar la acest decodor nu-i dau de cap.A facut cineva unul sau ceva sfaturi.Problema e ca dupa ce scriu PIC-ul si dau sa setez asa cum spune nu se intampla nimic.Am setat (incercat) sa setez cv513 pe 1 si ar trebui sa comute accesoriile de la 1 la 4..dar nimic :( Am folosit un multimouse si nanox sau centrala originala de la roco.Acum nici nu stiu daca se face modificarea sau nu.. :-x

Stima!
 
11 Mar 2008
39
0
Bistrita
LOCATION
Bistrita
#3
L-am scris si rascris.Am incercat 2 pic-uri diferite 16f84 si mai scrie ca se poate folosi si 16f628 cu hex-ul de rigoare.Am facut si asta.Nu sunt la primele picuri scrise..a mers din prima si cel de la nanoX-S88 si cel de la gen-li si cel de la minimouse.
 

sogard_2003

Well-Known Member
19 Ian 2016
3.604
0
Bucuresti
LOCATION
Bucuresti
#4
nu stiu ce sa zic.verifica inca o data schema si cablajul sa corespunda ...dar nu acum.ca acum pun pariu ca esti prea nervos sa reverifici.nu se poate sa nu mearga ,la altii a mers.vezi poate e optocuplorul de vina.
fa o poza cu spatele cablajului sa vad si eu minunea.
in caz ca apare Elef pe aici sa ii cerem si lui parerea.
 

d0ru_b

Well-Known Member
9 Noi 2008
364
0
Cluj-N / Lugoj
YAHOO
doru_basaliga
LOCATION
Cluj-N / Lugoj
#5
ar trebui sa verifici cuartul, nu e prima data cand se gresesc valorile in magazine, ceri de 8 si iti dau de 6 sau altceva. eu am patit/o. ar fi bun un osciloscop acum. bafta
 

shoppy

Well-Known Member
2 Mai 2007
655
0
Bucuresti, s. 1
YAHOO
shoppy_0
LOCATION
Bucuresti, s. 1
#6
Scump osciloscopul, mai repede maicumperi 2-3 cuarturi. Si un multimetru capabil de masurat condensatori ar fi bun, dar nici acela nu-i ieftin.
Incearca sa scrii in el un program simplu care sa clipeasca acel led (D2), ca sa te asiguri ca e scris si alimentat corect.
 
11 Mar 2008
39
0
Bistrita
LOCATION
Bistrita
#7
...iata..asa arata..frumos(zic eu) si nefunctional :-x
http://i131.photobucket.com/albums/p291/blueicon/Electronice/Picture056.jpg
http://i131.photobucket.com/albums/p291/blueicon/Electronice/Picture057.jpg
quartzul e de 8..sigur scrie pe el. :roll:
O sa schimb si quartzul..sa vad unde gasesc.
A fost verificat asa cum scrie la documentatie.Alimentare am..ledul e bine pus,optocuplorul schimbat ..uln schimbat.. ..ramane doar quartzul..sau sa termin si montajul 2..si sa nu mearga nici ala :mask:
 

d0ru_b

Well-Known Member
9 Noi 2008
364
0
Cluj-N / Lugoj
YAHOO
doru_basaliga
LOCATION
Cluj-N / Lugoj
#10
sigur nu ai scurturi pe placa? unele trasee sunt cam apropiate. ar trebui sa incerci sa dai afara chestiile care te incurca, as incerca sa elimin cumva optocuplorul si eventual sa masor direct pe iesirea din pic daca batzaie ceva port. sunt multe chestii care ar putea sa nu mearga, ar fi mai bine sa o lasi pe maine.
 

sogard_2003

Well-Known Member
19 Ian 2016
3.604
0
Bucuresti
LOCATION
Bucuresti
#11
ma tot uit la pozele alea de mi s-au incrutisat ochii. :D . daca nu am placa in mana e cam greu.vezi si cu trazeele alea,sa nu fi pus piesele pe dos,vreun traseu intrerupt....dar ti-am zis daca toate astea sunt bune sigur e ceva cu softul pe care il scrii in procesor.sau poate ai descarcat hex-ul cu erori...mai incearca o data de la zero rescrierea...resetarea calculatorului...reinstalarea programului de scriere....multa munca
 

dac

Well-Known Member
15 Sep 2007
1.298
0
Bucuresti
LOCATION
Bucuresti
#12
Din cate am inteles, microswitch-ul trebuie tinut apasat in timpul programarii; pt. adresa 1 trebuie sa scrii 1 in CV513 si 0 in CV521.
 
11 Mar 2008
39
0
Bistrita
LOCATION
Bistrita
#13
Da asa este ..microswitchul trebuie tinut apasat in timpul programarii..si ar trebui sa se aprinda led-ul..dar nu face (nici) asta.Da corect 1 in cv 513 daca sunt primele 4 sii tot asa 2 pentru 5-8 .... si 0 in cv521.In momentul in care scriu asta primesc error 2 pe multimouse daca folosesc nanoX si error 1 daca folosesc centrala de la roco.
Astazi o sa verific fiecare traseu in parte.
 

shoppy

Well-Known Member
2 Mai 2007
655
0
Bucuresti, s. 1
YAHOO
shoppy_0
LOCATION
Bucuresti, s. 1
#14
Mi-am intrebat prietenul specialist, a observat asa (de la stanga la dreapta):
You do not have permission to view link Autentificare sau înregistrare acum

-unul din condensatorii cuartului pare in scurt
-acolo e un cablaj ars sau oricum ceva ciudat
-pin neconectat, initial credeam ca e butonul, apoi am vazut ca butonul e jos, si el are doi pini neconectati, asigura-te ca e conectat corect butonul
-aici pare un scurt intre vcc si gnd

Alte idei ar mai fi:
-cuartul se poate sa fie bun, nu e neaparat ars
-verifica daca nu ai montat ledul pe dos
-MCLR ar trebuii legat printr-o rezistenta la vcc, nu asa direct
 
11 Mar 2008
39
0
Bistrita
LOCATION
Bistrita
#15
..no boon..hai ca i-am dat de capat..pe 1/2 sa zic asa.Am schimbat sursa de 5 v si acu merge.Din scrierea pic-ului merge pe 5-8 ca nr de macaz..merge brici.Dar nicicum nu reusesc sa programez CV 513.Poate ma ajuta specialistii in digital.Am multimouse si din ce am citit doar in mod POM se pot programa cv-uri mai mari parca.Nici cu Panelpro JMRI nu reusesc.Comuta cele 4 macaze pe pozitiile 5-8 si atat.Oricum e superba jucaria si am deja comanda pentru 4 macaze.Daca as reusi sa programez unul pe pozitiile 1-4 as fi multumit.Eventual poate ar merita sapat prin HEX.
 
11 Mar 2008
39
0
Bistrita
LOCATION
Bistrita
#16
Gata domnilor.Montajul functioneaza 100% .Nu am reusit modificarea lui cv513 nicicum cu ajutorul MM,dar modificarile se fac in hex si se programeaza PIC-ul din start cu ce avem nevoie.De pe site-ul de unde am luat schema am primit si ajutor in ceea ce priveste HEX-ul si pana la urma am facut cu PIC16f628 aceste fiind la 1/2 pret fata de cel initial.Multumesc tuturor pentru ajutor!